505 bei PHP-Anwendungen während Updates und Installationen

Veröffentlicht am 4. September 2011 von Germeshausen.de No Comments

Bei der Installation, Erweiterung oder Aktualisierung von PHP-Anwendungen gibt der Server bei PHP via FastCGI den Fehler 505 zurück. Entsprechende Parameter für den Dateiupload, maximale Größe von Posts etc. sind eigentlich korrekt eingestellt. Interessanterweise funktioniert es als Apache-Modul oder CGI ohne diesen Fehler und Tritt bei FastCGI nur bei Dateien auf, die eine bestimmte Größe überschreitet.

Ursache hier war der PHP-Wert FcgidMaxRequestLen, welcher während der letzten Serveraktualisierungen auf 128 kb geschrumpft ist. Diese agiert als Nadelöhr unabhängig von den anderen Einstellungen. Den Wert in der Datei /etc/apache2/mods-available/fcgid.conf ergänzt und selbst bestimmt, behob das Problem:

FcgidMaxRequestLen 134217728

Abschließend den Webserver einmal neu laden und danach klappten auch die Installation und Updates in WordPress, sowie die Installation von Komponten und Modulen in Joomla.

Notiz an meine persönliche ToDo für zukünftigen Neuinstallationen von Webservern:

  • Die Konfiguration entsprechend erweitern.
Auf unseren Kundensystemen ist bereits alles angepasst.

Keine Kommentare

Schreibe einen Kommentar